Pantalla azul BSOD con código de error 0x00000050 (PAGE_FAULT_IN_NONPAGED_AREA) en igdpmd64.sys

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Descripción: 

Puede aparecer una pantalla de parada (pantallazo azul o Blue Screen of Death), mostrando el error de Windows

0x00000050 (PAGE_FAULT_IN_NONPAGED_AREA)

en igdpmd64.sys mientras se navega por Internet con Internet Explorer.

Causa: 

igdpmd64.sys es un componente del driver de la tarjetas gráficas de la serie Intel HD Graphics para sistemas operativos de 64 bits. El problema aparece cuando el navegador intenta acceder a ciertas funcionalidades de la tarjeta gráfica que contienen un error. El error parece estar relacionado con la instalación de la actualización KB2670838 de Internet Explorer.

Dificultad: 
Intermedio
Solución: 

Actualizado 25/03/13 12:00

Para solucionar este problema, se deberá descargar e instalar el driver actualizado correspondiente a la tarjeta gráfica instalada.

Para ello, se deberá acceder a la página web del fabricante del ordenador, o al Centro de Descargas de Intel (aquí) y descargar el driver correspondiente al adaptador Intel HD Graphics.

Accederemos al Panel de Control, y desinstalaremos el controlador Intel HD Graphics actual. Si no apareciese dicha entrada, se puede acceder al Administrador de Dispositivos y desinstalar dicho adaptador, marcando la opción de Eliminar Software de Controlador.

Una vez reiniciado el equipo, se instalará el nuevo driver que tenemos descargado. Este driver también está disponible a través de Windows Update.

Otra solución pasa por desinstalar la actualización KB2670838, a través de Panel de Control -> Desinstalar un programas -> Ver actualizaciones instaladas. No obstante, ésta no sería una solución óptima, al tratarse éste de un problema de drivers, que podría reproducirse en un futuro con otras actualizaciones.

Si ninguna de las soluciones propuestas funciona correctamente, y aunque no sea la solución óptima, se deberán de guardar los datos y restablecer el equipo al estado de fábrica (formatear).

Consulta el artículo de la Base de Conocimiento Iniciar recuperación de Windows desde la partición oculta (Recovery) para obtener más información sobre el procedimiento de recuperación de los portátiles más habituales.

Detalle

Para llevar a cabo estas tareas, deberemos:

  1. Ir al Administrador de Dispositivos. Se puede abrir el Panel de Control, y hacer una búsqueda utilizando el recuadro de búsqueda en la esquina superior derecha.
  2. Una vez en el Administrador de Dispositivos, desplegamos la rama Adaptadores de Pantalla. Seleccionamos el adaptador Intel HD Graphics, y pulsamos el botón de Desinstalar (en la barra de botones, tiene una X roja). En la nueva ventana que aparece pidiéndonos confirmación, marcamos la opción de Eliminar el Software de Controlador.
  3. Ahora que tenemos el driver desinstalado, vamos al menú Acción, y seleccionamos Buscar Cambios del Hardware.
  4. Esto reinstalará el nuevo driver de forma automática. Para ello, el ordenador tiene que estar conectado a Internet.

Con estos pasos, ya tendremos el driver actual de Intel HD Graphics instalado. Únicamente resta reiniciar el equipo.

En ocasiones, es posible que aparezca un mensaje de error del otro adaptador gráfico instalado en el equipo (en este caso un adaptador AMD Radeon). En ese caso, puedes probar a seguir los mismos pasos con ese otro adaptador gráfico, solo que en el paso 2, no deberás marcar la opción de Eliminar Software de Controlador. Si esto no lo solucionase, entonces deberemos ir a la web del fabricante del ordenador, y descargar dicho driver actualizado. Es complicado poner aquí los métodos para todos los portátiles, por lo que, en caso de duda, plantéala en el foro, especificando el modelo de portátil, y te indicaremos cómo proceder.

Se aplica a: 
Windows Vista 64 bits
Windows 7 64 bits
Windows 8 64 bits